1. Home
  2. Docs
  3. Getting Started
  4. Requirements

Requirements

WP SmartPay is intentionally designed with few requirements. You can easily run WP SmartPay on your WordPress website, as well as 99% of all Web hosting providers. We generally follow web hosting guideline given by WordPress.org. Here’s what we recommend for running WP SmartPay:

  • WordPress 5.1 or higher
  • PHP 7.1.3 or higher
  • MySQL version 5.6 or higher OR MariaDB version 10.1 or higher.
  • HTTPS Support

WP SmartPay requires at least one payment gateway to activate. We recommend Paddle, sign up for a free Paddle account if you don’t have one yet.

SSL (HTTPS)

Every payment gateway including Paddle requires that any page hosting a live checkout form be SSL (they should start with https://). WordPress itself strongly recommends HTTPS for all sites. Modern browsers, and the incredible success of projects like Let’s Encrypt have made getting a certificate to secure your site fast, free, and something we think every host should support by default, especially in a post-Snowden era.

WordPress and PHP Version Support

WP SmartPay is built to be as backward compatible as possible. Just like WordPress itself, we believe in backward compatibility. But we strongly recommend to use latest version so you’ll have the best experience and get the best Support.

PHP 7.3 or higher is still strongly recommended for security and performance reasons we generally support a few versions back.

We strongly recommend updating WordPress to latest version for better performance and security. WP SmartPay works perfectly with WordPress 5.1 and beyond.

Was this article helpful to you? Yes No

How can we help?